Yes, please upgrade to V4.5 then V5.0 then V5.1